summary refs log tree commit diff
path: root/flake.nix
diff options
context:
space:
mode:
authorMalte Voos <git@mal.tc>2022-08-20 14:12:11 +0200
committerMalte Voos <git@mal.tc>2022-08-20 14:12:11 +0200
commitd0c70ad88b11f412c9d8c6735b74cce1b1ff015b (patch)
tree2f0e9821a785e083abfe851ce919cadbefe001af /flake.nix
parent5f22745507a343163521fbe85cdc72ac144c319f (diff)
downloadbwinf402-main.tar.gz
bwinf402-main.zip
cleanup main
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix23
1 files changed, 17 insertions, 6 deletions
diff --git a/flake.nix b/flake.nix
index a94eb7d..7706891 100644
--- a/flake.nix
+++ b/flake.nix
@@ -18,15 +18,26 @@
     {
       devShell = pkgs.mkShell {
         buildInputs = with pkgs; [
-          (fenix.packages.${system}.complete.withComponents [
-            "cargo"
-            "clippy"
-            "rust-src"
-            "rustc"
-            "rustfmt"
+          # (fenix.packages.${system}.complete.withComponents [
+          #   "cargo"
+          #   "clippy"
+          #   "rust-src"
+          #   "rustc"
+          #   "rustfmt"
+          # ])
+          (with fenix.packages.${system}; combine [
+            minimal.rustc
+            minimal.cargo
+
+            targets.x86_64-unknown-linux-musl.latest.rust-std
           ])
           rust-analyzer-nightly
           cargo-edit
+
+          hyperfine
+
+          texlive.combined.scheme-full
+          texlab
         ];
       };
     }