summary refs log tree commit diff
path: root/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml18
1 files changed, 14 insertions, 4 deletions
diff --git a/Cargo.toml b/Cargo.toml
index bb8d70f..952cf08 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -3,9 +3,19 @@ name = "life"
 version = "0.1.0"
 edition = "2021"
 
+[package.metadata.wasm-pack.profile.release]
+wasm-opt = false
+
+[lib]
+crate-type = ["cdylib", "rlib"]
+
 [dependencies]
-anyhow = "1.0.62"
-pixels = "0.9.0"
+anyhow = "1.0.70"
+getrandom = { version = "0.2.8", features = ["js"] }
+pixels = "0.12.0"
 rand = { version = "0.8.5", features = ["min_const_gen"] }
-winit = "0.27.2"
-winit_input_helper = "0.13.0"
+wasm-bindgen = "0.2.84"
+wasm-bindgen-futures = "0.4.34"
+web-sys = { version = "0.3.61", features = ["GpuTextureFormat"] }
+winit = "0.28.3"
+winit_input_helper = "0.14.1"