summary refs log tree commit diff
path: root/flake.nix
diff options
context:
space:
mode:
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix17
1 files changed, 10 insertions, 7 deletions
diff --git a/flake.nix b/flake.nix
index 9939f68..20e4c0e 100644
--- a/flake.nix
+++ b/flake.nix
@@ -12,19 +12,22 @@
     let
       pkgs = import nixpkgs {
         inherit system;
-        overlays = [ fenix.overlay ];
+        overlays = [ fenix.overlays.default ];
       };
     in
     {
       devShell = with pkgs; mkShell rec {
         nativeBuildInputs = [
-          (fenix.packages.${system}.complete.withComponents [
-            "cargo"
-            "clippy"
-            "rust-src"
-            "rustc"
-            "rustfmt"
+          (with fenix.packages.${system}; combine [
+            complete.cargo
+            complete.clippy
+            complete.rust-src
+            complete.rustc
+            complete.rustfmt
+            targets.wasm32-unknown-unknown.latest.rust-std
           ])
+          wasm-pack
+          wasm-bindgen-cli
           rust-analyzer-nightly
           cargo-edit