about summary refs log tree commit diff
path: root/flake.nix
diff options
context:
space:
mode:
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix4
1 files changed, 2 insertions, 2 deletions
diff --git a/flake.nix b/flake.nix
index 8c86952..aef5d65 100644
--- a/flake.nix
+++ b/flake.nix
@@ -163,9 +163,9 @@
 
             rsync --rsh="${ssh}" "$in" ${guest}:${documentDir}
             ${ssh} ${guest} "unzip '${documentDir}/$in_basename' -d ${documentDir}"
-            doc_id="$(${ssh} ${guest} find ${documentDir} -mindepth 1 -type d ! -name '\*.\*' -exec basename {} '\;')"
+            doc_id="$(${ssh} ${guest} find ${documentDir} -name '\*.metadata' -exec basename {} .metadata '\;')"
 
-            curl -o "$out" "http://127.0.0.1:${toString httpPort}/download/$doc_id/placeholder"
+            curl -f -o "$out" "http://127.0.0.1:${toString httpPort}/download/$doc_id/placeholder"
           '';
       };