about summary refs log tree commit diff
path: root/flake.nix
diff options
context:
space:
mode:
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix2
1 files changed, 1 insertions, 1 deletions
diff --git a/flake.nix b/flake.nix
index 31585b4..8c86952 100644
--- a/flake.nix
+++ b/flake.nix
@@ -162,7 +162,7 @@
             ${ssh} ${guest} mkdir ${documentDir}
 
             rsync --rsh="${ssh}" "$in" ${guest}:${documentDir}
-            ${ssh} ${guest} unzip "${documentDir}/$in_basename" -d ${documentDir}
+            ${ssh} ${guest} "unzip '${documentDir}/$in_basename' -d ${documentDir}"
             doc_id="$(${ssh} ${guest} find ${documentDir} -mindepth 1 -type d ! -name '\*.\*' -exec basename {} '\;')"
 
             curl -o "$out" "http://127.0.0.1:${toString httpPort}/download/$doc_id/placeholder"