about summary refs log tree commit diff
path: root/flake.nix
diff options
context:
space:
mode:
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix21
1 files changed, 19 insertions, 2 deletions
diff --git a/flake.nix b/flake.nix
index 889e68e..222eb14 100644
--- a/flake.nix
+++ b/flake.nix
@@ -1,7 +1,15 @@
 {
+  inputs = {
+    nixpkgs.url = "github:malte-v/nixpkgs/raspi3";
+    flake-utils.url = "github:numtide/flake-utils";
+  };
   outputs =
-    { self }:
     {
+      self,
+      nixpkgs,
+      flake-utils,
+    }:
+    flake-utils.lib.eachDefaultSystem (system: rec {
       overlays.default =
         final: prev:
         let
@@ -27,5 +35,14 @@
         {
           inherit reMder;
         };
-    };
+
+      packages.default =
+        let
+          pkgs = import nixpkgs {
+            inherit system;
+            overlays = [ overlays.default ];
+          };
+        in
+        pkgs.reMder;
+    });
 }