about summary refs log tree commit diff
path: root/server.nix
diff options
context:
space:
mode:
Diffstat (limited to 'server.nix')
-rw-r--r--server.nix6
1 files changed, 5 insertions, 1 deletions
diff --git a/server.nix b/server.nix
index eefab38..dc4fcd6 100644
--- a/server.nix
+++ b/server.nix
@@ -99,7 +99,10 @@ let
         mkfs vfat /dev/sda1
         upload ${rootfsImage} /dev/sda2
         resize2fs /dev/sda2
-        mkfs ext4 /dev/sda4
+        # we disable the orphan_file feature to avoid the error
+        # '/dev/vda4 has unsupported feature(s): FEATURE_C12'
+        # when e2fsck runs at boot
+        mkfs ext4 /dev/sda4 features:^orphan_file
 
         mount /dev/sda2 /
 
@@ -142,6 +145,7 @@ writeShellApplication {
   runtimeInputs = [ qemu ];
 
   text = ''
+    rm -f ./reMder.qcow2
     qemu-img create -b ${diskImage} -F qcow2 -f qcow2 ./reMder.qcow2
 
     qemu-system-aarch64 \