summary refs log tree commit diff
path: root/module.nix
diff options
context:
space:
mode:
Diffstat (limited to 'module.nix')
-rw-r--r--module.nix6
1 files changed, 3 insertions, 3 deletions
diff --git a/module.nix b/module.nix
index e60373d..c4f9a66 100644
--- a/module.nix
+++ b/module.nix
@@ -8,7 +8,7 @@ let
 
   # -------- implementation -------- #
 
-  cfg = config;
+  cfg = config.s6-rc;
 
   logNames = flatten (mapAttrsToList (_: sv: optional (sv.log != null) sv.log) cfg.longruns);
 
@@ -168,7 +168,7 @@ in
 {
   # -------- interface -------- #
 
-  options = with types;
+  options.s6-rc = with types;
     let
       mkNullableOption = { type, ... } @ o:
         mkOption o // { type = nullOr type; default = null; };
@@ -301,7 +301,7 @@ in
       };
     };
 
-  config = lib.mkIf checkAssertions {
+  config.s6-rc = lib.mkIf checkAssertions {
     inherit serviceSourceDir compiledDatabase;
   };
 }