about summary refs log tree commit diff
path: root/flake.nix
diff options
context:
space:
mode:
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix11
1 files changed, 8 insertions, 3 deletions
diff --git a/flake.nix b/flake.nix
index fa15c13..6be9e8b 100644
--- a/flake.nix
+++ b/flake.nix
@@ -1,13 +1,18 @@
 {
   inputs = {
+    nixpkgs.url = "github:NixOS/nixpkgs/nixos-unstable";
     opam-repository = {
       url = "github:ocaml/opam-repository";
       flake = false;
     };
-    opam-nix.url = "github:tweag/opam-nix";
-    opam-nix.inputs.opam-repository.follows = "opam-repository";
+    opam-nix = {
+      url = "github:tweag/opam-nix";
+      inputs = {
+        nixpkgs.follows = "nixpkgs";
+        opam-repository.follows = "opam-repository";
+      };
+    };
     flake-utils.url = "github:numtide/flake-utils";
-    nixpkgs.follows = "opam-nix/nixpkgs";
   };
 
   outputs = { flake-utils, opam-nix, nixpkgs, ... }: